您的位置:首页 > 其它

HDU1541 Stars(树状数组)

2016-02-28 13:32 357 查看

Stars

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7209 Accepted Submission(s): 2830

Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not
to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.


Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There
can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.


Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of
stars of the level N-1.


Sample Input
5
1 1
5 1
7 1
3 3
5 5




Sample Output
1
2
1
1
0




Source
Ural Collegiate Programming Contest 1999

题意:给n个星星,每个星星按y坐标从小到大,y一样x从小到大输入,然后每个星星的做下区域每包含一个星星(不包括自己),该星星就升一级;最后求等级0~n-1的星星的个数。
分析:树状数组基础入门题,也不知道怎么说,就属于模板题吧。推荐一篇博客,写的挺好:点击打开链接

<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 32010

int n,a[MAXN],sum[MAXN];

int lowbit(int x){ return x&(-x);}

int Sum(int n)///前n项的和
{
    int s = 0;
    while(n > 0)
    {
        s += a
;
        n -= lowbit(n);
    }
    return s;
}

void add(int x)///增加某个元素的大小
{
    while(x <= MAXN)
    {
        ++a[x];
        x += lowbit(x);
    }
}

int main()
{
    int x,y;
    while(~scanf("%d",&n))
    {
        CL(a, 0);
        CL(sum, 0);
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            x++;
            sum[Sum(x)]++;
            add(x);
        }
        for(int i=0; i<n; i++)
            cout<<sum[i]<<endl;
    }
    return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: