您的位置:首页 > 其它

HDU4046 Panda(线段树)

2016-03-14 21:03 169 查看

Panda

Time Limit: 10000/4000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3167 Accepted Submission(s): 1032

Problem Description
When I wrote down this letter, you may have been on the airplane to U.S.

We have known for 15 years, which has exceeded one-fifth of my whole life. I still remember the first time we went to the movies, the first time we went for a walk together. I still remember the smiling face you wore when you were dressing in front of the mirror.
I love your smile and your shining eyes. When you are with me, every second is wonderful.

The more expectation I had, the more disappointment I got. You said you would like to go to U.S.I know what you really meant. I respect your decision. Gravitation is not responsible for people falling in love. I will always be your best friend. I know the way
is difficult. Every minute thinking of giving up, thinking of the reason why you have held on for so long, just keep going on. Whenever you’re having a bad day, remember this: I LOVE YOU.

I will keep waiting, until you come back. Look into my eyes and you will see what you mean to me.

There are two most fortunate stories in my life: one is finally the time I love you exhausted. the other is that long time ago on a particular day I met you.

Saerdna.

It comes back to several years ago. I still remember your immature face.

The yellowed picture under the table might evoke the countless memory. The boy will keep the last appointment with the girl, miss the heavy rain in those years, miss the love in those years. Having tried to conquer the world, only to find that in the end, you
are the world. I want to tell you I didn’t forget. Starry night, I will hold you tightly.

Saerdna loves Panda so much, and also you know that Panda has two colors, black and white.

Saerdna wants to share his love with Panda, so he writes a love letter by just black and white.

The love letter is too long and Panda has not that much time to see the whole letter.

But it's easy to read the letter, because Saerdna hides his love in the letter by using the three continuous key words that are white, black and white.

But Panda doesn't know how many Saerdna's love there are in the letter.

Can you help Panda?



Input
An integer T means the number of test cases T<=100

For each test case:

First line is two integers n, m

n means the length of the letter, m means the query of the Panda. n<=50000,m<=10000

The next line has n characters 'b' or 'w', 'b' means black, 'w' means white.

The next m lines

Each line has two type

Type 0: answer how many love between L and R. (0<=L<=R<n)

Type 1: change the kth character to ch(0<=k<n and ch is ‘b’ or ‘w’)



Output
For each test case, output the case number first.

The answer of the question.



Sample Input
2

5 2
bwbwb
0 0 4
0 1 3
5 5
wbwbw
0 0 4
0 0 2
0 2 4
1 2 b
0 0 4




Sample Output
Case 1: 
1 
1 
Case 2: 
2 
1 
1 
0




Source
<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 500010

struct node
{
    int l,r,s;
}t[MAXN<<2];
int a[MAXN];///标记是否有wbw
int n,m;

void build(int l, int r, int i)
{
    t[i].l = l;
    t[i].r = r;
    if(l == r) {t[i].s = a[l]; return ;}
    int mid = (l+r)>>1;
    build(l, mid, i<<1);
    build(mid+1, r, i<<1|1);
    t[i].s = t[i<<1].s + t[i<<1|1].s;
}

void update(int x, int num, int i)
{
    if(t[i].l == t[i].r)
    {
        t[i].s = num;
        return ;
    }
    int mid = (t[i].l+t[i].r)>>1;
    if(x <= mid) update(x, num, i<<1);
    else update(x, num, i<<1|1);
    t[i].s = t[i<<1].s + t[i<<1|1].s;
}

int query(int l, int r, int i)
{
    if(t[i].l==l && t[i].r==r)
        return t[i].s;
    int mid = (t[i].l+t[i].r)>>1;
    if(r <= mid) return query(l, r, i<<1);
    else if(l > mid) return query(l, r, i<<1|1);
    else
        return query(l, mid, i<<1) + query(mid+1, r, i<<1|1);
}

int main()
{
    int T;
    char str[MAXN];
    int L,R,x,k;
    char ch;
    scanf("%d",&T);
    for(int cas=1; cas<=T; cas++)
    {
        scanf("%d%d",&n,&m);
        scanf("%s",str);
        CL(a, 0);
        for(int i=1; i<n-1; i++)
        {
            if(str[i]=='b'&&str[i-1]=='w'&&str[i+1]=='w')
                a[i] = 1;
            else a[i] = 0;
        }
        build(1, n, 1);
        printf("Case %d:\n",cas);
        while(m--)
        {
            scanf("%d",&k);
            if(k == 0)
            {
                scanf("%d%d",&L,&R);
                ///小细节,以L和R为中点的字符串并不可能构成wbw
                if(L+1 > R-1) puts("0");
                else printf("%d\n",query(L+1, R-1, 1));
            }
            else
            {
                scanf("%d %c",&x,&ch);
                if(str[x] == ch) continue;
                str[x] = ch;
                ///注意边界
                if(x>1&&str[x-2]=='w'&&str[x-1]=='b'&&str[x]=='w')
                {
                    if(a[x-1] == 0)///如果之前不是wbw,更改某字符后构成了wbw
                        update(x-1, 1, 1);
                    a[x-1] = 1;///标记该点是wbw
                }
                else if(x>1&&a[x-1]==1)///之前就是wbw,更改某一字符后必定不是wbw
                {
                    update(x-1, 0, 1);
                    a[x-1] = 0;
                }
                ///下面的和上面道理一样
                if(x>0&&x<n-1&&str[x-1]=='w'&&str[x]=='b'&&str[x+1]=='w')
                {
                    if(a[x] == 0)
                        update(x, 1, 1);
                    a[x] = 1;
                }
                else if(x>0&&x<n-1&&a[x]==1)
                {
                    update(x, 0, 1);
                    a[x] = 0;
                }
                if(x<n-2&&str[x]=='w'&&str[x+1]=='b'&&str[x+2]=='w')
                {
                    if(a[x+1] == 0)
                        update(x+1, 1, 1);
                    a[x+1] = 1;

                }
                else if(x<n-2&&a[x+1]==1)
                {
                    update(x+1, 0, 1);
                    a[x+1] = 0;
                }
            }
        }
    }
    return 0;
}
</span>


The 36th ACM/ICPC Asia
Regional Beijing Site —— Online Contest

题意:一个只含有w和b的字符串,每次输出一个区间内含有多少个‘wbw’字符串,或者改变一个字符。
分析:线段树单点更新,区间查询。对于原串,用一个数组来标记该点的左右是否构成‘wbw’,是为1,否为0。
Ps:有些东西并不能直接得到答案,稍微变化下自己的思维,答案就很明了了,线段树的题还是做的太少了。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: