您的位置:首页 > 其它

poj3660 Cow Contest

2016-03-06 16:28 330 查看
Cow Contest

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8986Accepted: 5045
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is
unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B),
then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It
is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

 

Sample Input
5 5
4 3
4 2
3 2
1 2

Sample Output
2

Source
USACO 2008 January Silver

题意:n头牛,给出一部分牛的排名情况,求最后确定排名的牛的头数。
分析:。。。。坑的一逼,不想说话,我想静静。

<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 100010

int n,m;
int s[105][105];

int main()
{
    int a,b;
    while(scanf("%d%d",&n,&m)==2)
    {
        CL(s, 0);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            s[a][b] = 1;
        }
        int sum = 0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                for(int k=1; k<=n; k++)
                {
                    if(s[j][i]&&s[i][k])
                        s[j][k] = 1;
                }
            }
        }
        for(int i=1; i<=n; i++)
        {
            int t=0;
            for(int j=1; j<=n; j++)
            {
                t = t+s[i][j]+s[j][i];
            }
            if(n-t == 1) sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: