您的位置:首页 > 其它

1104. Sum of Number Segments (20)

2016-02-20 19:35 267 查看
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4

0.1 0.2 0.3 0.4

Sample Output:

5.00

此类题型需要注意:

1、float可能会出错,尽量用double

2、仔细观察数学规律,当出错时,试着推导另一条公式。

#include<iostream>
using namespace std;
int main(){
freopen("in.txt","r",stdin);
int n,tn;
double all=0,t;
cin>>n;
tn=n;
for(int i=1;i<=n;i++)
{
cin>>t;
//all+=(tn*t);
//tn+=(n-2*i);
all+=t*i*(n+1-i);
}
printf("%.2f",all);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: