您的位置:首页 > 产品设计 > UI/UE

1101. Quick Sort (25)

2016-02-22 08:48 423 查看
There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;

3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;

2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;

and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5

1 3 2 4 5

Sample Output:

3

1 4 5

本题有个4分的case很难察觉,如果没有一个数符合要求,则输出0后,必须换行2次。

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
#define maxn 100005
long long maxa[maxn]={0},mina[maxn],a[maxn];
int main(){
int n;
vector<long long> out;
cin>>n;
maxa[0]=0;
for(int i=1;i<=n;i++){
cin>>a[i];
maxa[i]=max(a[i],maxa[i-1]);
}
mina
=a
;
for(int i=n-1;i>0;i--){
mina[i]=min(mina[i+1],a[i]);
}
for(int i=1;i<=n;i++){
if(a[i]>=maxa[i]&&a[i]<=mina[i]){
out.push_back(a[i]);
}
}
cout<<out.size()<<endl;
if(!out.empty()){
cout<<out[0];
for(int i=1;i<out.size();i++){
cout<<" "<<out[i];
}
}
cout<<endl;//必须换行
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: