您的位置:首页 > 其它

1029. Median (25)

2016-02-21 16:41 253 查看

本题的输入应该使用scanf,否则会发送超时。在考场上,应当尽量使用scanf.

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input

4 11 12 13 14

5 9 10 15 16 17

Sample Output

13

#include<iostream>
using namespace std;
#define maxn 1000005
#define INF 0x7fffffff
int a[maxn],b[maxn];
int main(){
freopen("in.txt","r",stdin);
int n1,n2,k1=0,k2=0;
scanf("%d",&n1);
for(int i=0;i<n1;i++)
scanf("%d",&a[i]);
scanf("%d",&n2);
for(int i=0;i<n2;i++)
scanf("%d",&b[i]);
a[n1]=b[n2]=INF;
int mid=(n1+n2-1)/2;
while(k1+k2<mid){
if(a[k1]>b[k2]){
k2++;
}
else k1++;
}
if(a[k1]>b[k2])
cout<<b[k2];
else cout<<a[k1];
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: