您的位置:首页 > 其它

USACO 1.1 Milking Cows

2015-08-29 06:16 246 查看
Milking Cows

Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins
at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between
the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).
Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):
The longest time interval at least one cow was milked.
The longest time interval (after milking starts) during which no cows were being milked.

PROGRAM NAME: milk2

INPUT FORMAT

Line 1:The single integer
Lines 2..N+1:Two non-negative integers less than 1,000,000, respectively the starting and ending time in seconds after 0500

SAMPLE INPUT (file milk2.in)

3
300 1000
700 1200
1500 2100

OUTPUT FORMAT

A single line with two integers that represent the longest continuous time of milking and the longest idle time.

SAMPLE OUTPUT (file milk2.out)

900 300


题解:应该算是道超级简单的题 晚上失眠到五点半 索性不睡了。迷迷糊糊码下这道题 竟然一遍就过了

ps:本人大三狗一枚,正在持续更新博客,文章里有任何问题,希望各位网友可以指出。若有疑问也可在评论区留言,我会尽快回复。希望能与各位网友互相学习,谢谢!

/*
ID: cxq_xia1
PROG: milk2
LANG: C++
*/
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
const int maxn=5005;
int N;
struct node
{
int begins,ends;
friend bool operator < (node a,node b)
{
return a.begins > b.begins;
}

};
node farmers[maxn];
int main()
{
int ansMilk,ansNoMilk;
node tmp1,MilkTime,NoMilkTime;
freopen("milk2.in","r",stdin);
freopen("milk2.out","w",stdout);
while(cin >> N)
{
priority_queue<node> q;
for(int i=0;i<N;i++)
{
cin >> farmers[i].begins >> farmers[i].ends;
q.push(farmers[i]);
}
tmp1=q.top();
q.pop();
MilkTime=tmp1;
ansMilk=MilkTime.ends-MilkTime.begins;
ansNoMilk=0;
while(!q.empty())
{
tmp1=q.top();
q.pop();
if(tmp1.begins>MilkTime.ends)
{
NoMilkTime.begins=MilkTime.ends;
NoMilkTime.ends=tmp1.begins;
if(ansNoMilk<(tmp1.begins-MilkTime.ends))
ansNoMilk=NoMilkTime.ends-NoMilkTime.begins;

MilkTime=tmp1;
if(ansMilk<MilkTime.ends-MilkTime.begins)
ansMilk=MilkTime.ends-MilkTime.begins;
}
else
{
if(tmp1.ends>MilkTime.ends)
{
MilkTime.ends=tmp1.ends;
if(ansMilk<MilkTime.ends-MilkTime.begins)
ansMilk=MilkTime.ends-MilkTime.begins;
}
}
}
cout <<ansMilk<<" "<<ansNoMilk<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  USACO