您的位置:首页 > 其它

USACO 1.2 Dual Palindromes

2015-09-03 14:45 162 查看
Dual Palindromes

Mario Cruz (Colombia) & Hugo Rickeboer (Argentina)

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor
trailing zeroes, so 0220 is not a palindrome.
The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).
Write a program that reads two numbers (expressed in base 10):
N (1 <= N <= 15)
S (0 < S < 10000)
and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).
Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

PROGRAM NAME: dualpal

INPUT FORMAT

A single line with space separated integers N and S.

SAMPLE INPUT (file dualpal.in)

3 25

OUTPUT FORMAT

N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

SAMPLE OUTPUT (file dualpal.out)

26
27
28


题解: 输入 N 和 S。找出前N个 大于S且转换成其他进制 有两种以上是回文数,输出他。

ps:本人大三狗一枚,正在持续更新博客,文章里有任何问题,希望各位网友可以指出。若有疑问也可在评论区留言,我会尽快回复。希望能与各位网友互相学习,谢谢!

/*
ID: cxq_xia1
PROG: dualpal
LANG: C++
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int N,S,cntNumPal,cntLen;
char trans[50];
bool isPalsquare(char a[])
{
for(int i=0;i<cntLen;i++)
{
if(i==0&&a[i]==0)
return false;
if(trans[i]!=trans[cntLen-1-i])
return false;
}
return true;
}

int main()
{
freopen("dualpal.in","r",stdin);
freopen("dualpal.out","w",stdout);

cin >> N >> S;
int cnt=1;
for(int i=1;cnt<=N;i++)
{
cntNumPal=0;
for(int base=2;base<=10;base++)
{
int tmp=S+i;
memset(trans,0,sizeof(trans));
cntLen=0;
while(tmp!=0)
{
trans[cntLen++]=tmp%base;
tmp/=base;
}
if(isPalsquare(trans))
{
cntNumPal++;
}

if(cntNumPal>=2)
break;
}
if(cntNumPal>=2)
{
cout << S+i <<endl;
cnt++;
continue;
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  USACO