您的位置:首页 > 大数据 > 人工智能

poj 1995 Raising Modulo Numbers【快速幂】

2015-08-22 14:31 435 查看
Raising Modulo Numbers

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 5477Accepted: 3173
Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.
Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#define DD double
#define LL long long
#define INF 0x3f3f3f
#define MAX 1010
using namespace std;
int fun(int a,int b,int c)
{
int ans=1;
a=a%c;
while(b)
{
if(b&1)
ans=(a*ans)%c;
b=b/2;
a=(a*a)%c;
}
return ans;
}
int main()
{
int t,i,j;
int n,m,sum;
int x,y;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&m,&n);
sum=0;
for(i=1;i<=n;i++)
{
scanf("%d%d",&x,&y);
sum=fun(x,y,m)+sum;
}
printf("%d\n",sum%m);
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: