您的位置:首页 > 大数据 > 人工智能

POJ 1218 THE DRUNK JAILER

2015-08-19 21:13 477 查看
THE DRUNK JAILER
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 25129Accepted: 15772
Description
A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.

One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the

hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He

repeats this for n rounds, takes a final drink, and passes out.

Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.

Given the number of cells, determine how many prisoners escape jail.

Input
The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.


Output
For each line, you must print out the number of prisoners that escape when the prison has n cells.


Sample Input
2
5
100


Sample Output
2
10



这是我AC的代码。



#include<stdio.h>
#include<string.h>
int vis[110];

int main(){
	int t, n;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		memset(vis, 0 ,sizeof(vis));
		int i, j, k;
		for(i = 2; i <= n; ++i){
			k = i;
			for(j = 1; k <=n; ++j){
				k = j * i;
				if(vis[k] == 0) vis[k] = -1;
				else vis[k] = 0;
			}	
		}
		for(i = 1, j = 0; i <= n; ++i){
			if(vis[i] == 0) ++j;
		}
		printf("%d\n", j);
	}
	return 0;
}


另一种简单写法,是找规律来做的题。,别人的思路:

这题很简单,但是如果你利用循环把程序跑N遍,上交后,会提示TIMEOVER,,这题要总结规律。

当N=1, 最后打开的是1;N=2和3,打开还是1; N=4, 打1,4;,,,当N=9, 打开1,4,9;,,N=100, 打开1,4,9,16,25,。。。

为什么呢?

我们知道每个数打开的次数其实就是它因数的个数,,所以要想最后是打开状态,则要求有奇数的因数。

1)当数为质数时,就两个因数,不会打开;

2)当数不是完全平方数时(即N !=i*i),则对于任意因数k,必成对的存在另一个因数N/k。所以它有两个因数。最后不会打开

3)当数十完全平方数时,只有奇数个因数(因为i和i重复)最后会被打开。



而要求N以内完全平方数的个数,最简单莫过于直接对N开方取整就可以了

网址:http://blog.csdn.net/gytanonymous/article/details/7176952
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: