您的位置:首页 > 大数据 > 人工智能

nyoj77开灯问题 VS poj1218 THE DRUNK JAILER(开关灯问题模板)

2015-08-19 21:00 483 查看

开灯问题

时间限制:3000 ms | 内存限制:65535 KB
难度:1

描述
有n盏灯,编号为1~n,第1个人把所有灯打开,第2个人按下所有编号为2 的倍数的开关(这些灯将被关掉),第3 个人按下所有编号为3的倍数的开关(其中关掉的灯将被打开,开着的灯将被关闭),依此类推。一共有k个人,问最后有哪些灯开着?输入:n和k,输出开着的灯编号。k≤n≤1000

输入输入一组数据:n和k输出输出开着的灯编号样例输入
7 3

样例输出
1 5 6 7


<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
int a[10000]; //数组要开大点 
int main()
{
	int n,m;
	while(~scanf("%d %d",&n,&m))//有n个数,进行几轮,第一轮都开开门,第二轮关上(打开)是二的倍数,以此类推 
	{
		memset(a,0,sizeof(a));//数组清空,开门为0,所以,第一轮都开门。 
		int i,k,j;
		for(i=2;i<=m;i++)
		{
			k=i;
			for(j=1;k<=n;j++)
			{
				k=i*j;//找出第m轮m的倍数,并检查是否在n的范围内 
				if(a[k]==0)
				a[k]=-1;//关门为-1 
				else
				a[k]=0;
			}
		}
		printf("1");
		for(i=2;i<=n;i++)
		{
		if(a[i]==0)
		printf(" %d",i);
		}	
		printf("\n");	
	}
	return 0;
}




THE DRUNK JAILER

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 25125Accepted: 15768
Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.

One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the

hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He

repeats this for n rounds, takes a final drink, and passes out.

Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.

Given the number of cells, determine how many prisoners escape jail.
Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells.

Sample Input
2
5
100

Sample Output
2
10

<span style="color:#464646;">#include<stdio.h>
#include<string.h>
int main()
{
	int n,t,a[1000],i,j,k;
	scanf("%d",&t);
	while(t--)
	{	
		scanf("%d",&n);
		memset(a,0,sizeof(a));
	
		for(i=2;i<=n;i++)
		{	
			k=i;
			for(j=1;k<=n;j++)
			{
				k=i*j;
				if(a[k]==0)
				a[k]=-1;
				else
				a[k]=0;
			}
		}
		int j=0;
		for(i=1;i<=n;i++)
		{
			if(a[i]==0)
			j++;
		}
		printf("%d\n",j);
	}
	return 0;
}
#include<stdio.h>
#include<math.h>
int main()
{
	int T,n,m;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
	m=sqrt(n);
	printf("%d\n",m);
	}
	return 0;
}


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: