您的位置:首页 > 大数据 > 人工智能

THE DRUNK JAILER 1218

2015-08-19 21:09 411 查看
THE DRUNK JAILER

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25129 Accepted: 15772
Description
A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.

One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the

hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He

repeats this for n rounds, takes a final drink, and passes out.

Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.

Given the number of cells, determine how many prisoners escape jail.
Input
The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.

Output
For each line, you must print out the number of prisoners that escape when the prison has n cells.

Sample Input
2
5
100

Sample Output
2
10

//题意::警察喝醉开门问题,有n个门,第一次将所有门都打开,第二次将是2的倍数的都锁住
//		  第三次将所有3的倍数的都锁住,如果已经锁住了,就将其打开,一直进行
//		  此过程直到n次,问还剩多少门是开着的。
#include<stdio.h>
#include<string.h>
int vis[110];
int main(){
int t,n,i,j;
scanf("%d",&t);
while(t--)
{
int a=0;
memset(vis,0,sizeof(vis));
scanf("%d",&n);
for(i=2;i<=n;i++)
{
for(j=i;j<=n;j+=i)
{
if(!vis[j])
vis[j]=1;
else
vis[j]=0;
}
}
for(i=1;i<=n;i++)
if(vis[i]==0)
a++;
printf("%d\n",a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: