您的位置:首页 > 其它

UVA 10010 Where's Waldorf?

2015-08-06 18:46 489 查看
Given a m by n grid of letters, (1  m; n  50), and a list of words, nd the location in the grid at

which the word can be found.

A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters

in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The

matching can be done in any of the eight directions either horizontally, vertically or diagonally through

the grid.

Input

The input begins with a single positive integer on a line by itself indicating the number

of the cases following, each of them as described below. This line is followed by a blank

line, and there is also a blank line between two consecutive inputs.

The input begins with a pair of integers, m followed by n, 1  m; n  50 in decimal notation on a

single line. The next m lines contain n letters each; this is the grid of letters in which the words of the

list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters,

another integer k appears on a line by itself (1  k  20). The next k lines of input contain the list of

words to search for, one word per line. These words may contain upper and lower case letters only (no

spaces, hyphens or other non-alphabetic characters).

Output

For each test case, the output must follow the description below. The outputs of two

consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding

word in the grid must be output. The integers must be separated by a single space. The rst integer

is the line in the grid where the rst letter of the given word can be found (1 represents the topmost

line in the grid, and m represents the bottommost line). The second integer is the column in the grid

where the rst letter of the given word can be found (1 represents the leftmost column in the grid, and

n represents the rightmost column in the grid). If a word can be found more than once in the grid,

then the location which is output should correspond to the uppermost occurence of the word (i.e. the

occurence which places the rst letter of the word closest to the top of the grid). If two or more words

are uppermost, the output should correspond to the leftmost of these occurences. All words can be

found at least once in the grid.

Sample Input

1

8 11

abcDEFGhigg

hEbkWalDork

FtyAwaldORm

FtsimrLqsrc

byoArBeDeyv

Klcbqwikomk

strEBGadhrb

yUiqlxcnBjf

4

Waldorf

Bambi

Betty

Dagbert

Sample Output

2 5

2 3

1 2

7 8

答案:

#include<iostream>
#include<cstring>
#include <stdio.h>
//#include< cctype>

using namespace std;
char term[51][51];
char t[50];
void f (int m,int n,int len) {
int i,j,k,x,y;
for (i = 0;i <m;i++) {
for (j = 0;j < n;j++) {
if (term[i][j] == t[0]) {
x=i;y=j;k=0;
while (x > 0 && term[x-1][y]==t[k+1]) {
k++;x--; }//up
if (k==len-1) {
cout<<i+1<<' '<<j+1<<endl;
return ; }
x=i;y=j;k=0;
while (x < m-1 && term[x+1][y]==t[k+1]) {
x++;k++; }//down
if (k==len-1) {
cout<<i+1<<' '<<j+1<<endl;
return ; }
x=i;y=j;k=0;
while (y > 0 && term[x][y-1]==t[k+1]) {
k++;y--; }//left
if (k==len-1) {
cout<<i+1<<' '<<j+1<<endl;
return ; }
x=i;y=j;k=0;
while (y<n-1 && term[x][y+1]==t[k+1]) {
k++;y++; } //right
if (k==len-1) {
cout<<i+1<<' '<<j+1<<endl;
return ; }
x=i;y=j;k=0;
while (x>0 && y>0 && term[x-1][y-1]==t[k+1]) {
k++;y--;x--; } //left-up
if (k==len-1) {
cout<<i+1<<' '<<j+1<<endl;
return ; }
x=i;y=j;k=0;
while (x<m-1 && y<n-1 && term[x+1][y+1]==t[k+1]) {
k++;y++;x++; }//right-down
if (k==len-1) {
cout<<i+1<<' '<<j+1<<endl;
return ; }
x=i;y=j;k=0;
while (x>0 && y<n-1 && term[x-1][y+1]==t[k+1]) {
k++;x--;y++; }//right-up
if (k==len-1) {
cout<<i+1<<' '<<j+1<<endl;
return ; }
x=i;y=j;k=0;
while (x<m-1 && y>0 && term[x+1][y-1]==t[k+1]) {
k++;y--;x++; }//left-down
if (k==len-1) {
cout<<i+1<<' '<<j+1<<endl;
return ; }
}
}
}
}
int main() {
int u,m,n,k,j,i,len;
cin>>u;
while (u--) {
cin>>m>>n;
for (i = 0;i < m;i++) {
for (j = 0;j < n;j++) {
cin>>term[i][j];
term[i][j] = toupper(term[i][j]);
}
}
cin>>k;
getchar();
while(k--) {
gets(t);
len =strlen(t);
for (i = 0;i < len;i++)
t[i] = toupper(t[i]);
f(m,n,len);
}
if (u!=0)
cout<<endl;
}
return 0;}
这道题是刚来实验室的时候看着题解做的,结果一直都提交不了,今天只是把头文件改了一下,居然就可以了,想想都觉得略可怕!!!!!!!!!!!!!!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: