您的位置:首页 > 其它

UVA 10474 Where is the Marble?

2015-08-09 10:01 190 查看
yiyi:用两个数组,一个a,一个b.先把a用qsort(),排序,再在a中找看有没b中的元素,如果有,输出它在a中最小的位置,因为位置要从一开始算,所以输出位置时要加一。

还要注意一下数组的大小,我一开始开的很小,就过不了。

Where is the Marble?

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place
the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails.
After some fixed number of trials the game ends and the player with maximum points wins. Today it's your chance to play as Raju. Being the smart kid, you'd be taking the favor of a computer. But don't underestimate Meena, she had written a program to keep
track how much time you're taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number
of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers
are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written
upon any of the marbles. The two different formats are described below:

`x found at y', if the first marble with number x was found at position y. Positions are numbered 1, 2,..., N.

`x not found', if the marble with number x is not present.

Look at the output for sample input for details.

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

答案:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include<stdlib.h>
using namespace std;
int comp (const void *a, const void *b) {
return (*(int*)a - *(int*)b);
}
int main () {
int a[10000], b[10000];
int n, q, j, i, term = 1;
while (scanf("%d %d", &n, &q) != EOF) {
if (n ==0 && q == 0)
break;
printf("CASE# %d:\n", term);
term++;
memset(a, 0, sizeof(a));
memset(b, 0, sizeof(b));
for (i = 0; i < n; i++)
scanf("%d", &a[i]);
for(i = 0; i < q; i++)
scanf("%d", &b[i]);
qsort(a, n, sizeof(a[0]), comp);
for (i = 0; i < q; i++) {
int flags = 0;
for (j = 0; j < n; j++) {
if (a[j] == b[i]) {
printf("%d found at %d\n", b[i], j+1);
flags = 1;
break;
}
}
if (!flags)
printf("%d not found\n", b[i]);
}
}
//system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: