您的位置:首页 > 大数据 > 人工智能

hdu-----(1151)Air Raid(最小覆盖路径)

2014-08-21 22:33 351 查看

Air Raid

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3378 Accepted Submission(s): 2223


[align=left]Problem Description[/align]
Consider
a town where all the streets are one-way and each street leads from one
intersection to another. It is also known that starting from an
intersection and walking through town's streets you can never reach the
same intersection i.e. the town's streets form no cycles.

With
these assumptions your task is to write a program that finds the minimum
number of paratroopers that can descend on the town and visit all the
intersections of this town in such a way that more than one paratrooper
visits no intersection. Each paratrooper lands at an intersection and
can visit other intersections following the town streets. There are no
restrictions about the starting intersection for each paratrooper.

[align=left]Input[/align]
Your
program should read sets of data. The first line of the input file
contains the number of the data sets. Each data set specifies the
structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The
first line of each data set contains a positive integer
no_of_intersections (greater than 0 and less or equal to 120), which is
the number of intersections in the town. The second line contains a
positive integer no_of_streets, which is the number of streets in the
town. The next no_of_streets lines, one for each street in the town, are
randomly ordered and represent the town's streets. The line
corresponding to street k (k <= no_of_streets) consists of two
positive integers, separated by one blank: Sk (1 <= Sk <=
no_of_intersections) - the number of the intersection that is the start
of the street, and Ek (1 <= Ek <= no_of_intersections) - the
number of the intersection that is the end of the street. Intersections
are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

[align=left]Output[/align]
The
result of the program is on standard output. For each input data set
the program prints on a single line, starting from the beginning of the
line, one integer: the minimum number of paratroopers required to visit
all the intersections in the town.

[align=left]Sample Input[/align]

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

[align=left]Sample Output[/align]

2
1

[align=left]Source[/align]
Asia 2002, Dhaka (Bengal)

代码:

#include<cstring>
#include<cstdio>
#include<cstdlib>
using namespace std;
int const maxn=122;
int n,m;
bool mat[maxn][maxn];
bool vis[maxn];
int mac[maxn];
bool match(int x)
{
for(int i=1;i<=m;i++)
{
if(mat[x][i]&&!vis[i]){
vis[i]=1;
if(!mac[i]||match(mac[i])){
mac[i]=x;
return 1;
}
}
}
return 0;
}
int main(){
int a,b;
int test;
//freopen("test.in","r",stdin);
scanf("%d",&test);
while(test--){
scanf("%d%d",&m,&n);
memset(mat,0,sizeof(mat));
memset(mac,0,sizeof(mac));
for(int i=0;i<n;i++){
scanf("%d%d",&a,&b);
mat[a][b]=1;
}

int ans=0;
for(int i=1;i<=m;i++){
memset(vis,0,sizeof(vis));
if(match(i))ans++;
}
printf("%d\n",m-ans);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: