您的位置:首页 > 大数据 > 人工智能

poj 1422&&HDU 1151 Air Raid(最小路径覆盖)

2014-11-01 15:44 519 查看
Air Raid

点击打开题目链接

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 6781Accepted: 4045
Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets
form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper
lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections

no_of_streets

S1 E1

S2 E2

......

Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets
in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk
<= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input
2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output
2
1

Source
题目:一个图中有n个小镇和链接小镇的有向边,现在想空投一些伞兵,使得伞兵从起点走到终点能遍历所有的小镇(每个小镇只能空头一个伞兵),问最小需要多少个伞兵?
求二分图的最小路径覆盖!Why??一开始并不知道要求最小路径覆盖,大概想了一下,用小镇的个数减去最大匹配数应该就是,试了下,果然过了。事后看了下题解说用最小路径覆盖;
先看一下最小路径覆盖:

最小路径覆盖

最小路径覆盖(path covering):是“路径” 覆盖“点”,即用尽量少的不相交简单路径覆盖有向无环图G的所有顶点,即每个顶点严格属于一条路径。路径的长度可能为0(单个点)。

最小路径覆盖数=G的点数-最小路径覆盖中的边数。应该使得最小路径覆盖中的边数尽量多,但是又不能让两条边在同一个顶点相交。拆点:将每一个顶点i拆成两个顶点Xi和Yi。然后根据原图中边的信息,从X部往Y部引边。所有边的方向都是由X部到Y部。因此,所转化出的二分图的最大匹配数则是原图G中最小路径覆盖上的边数。因此由最小路径覆盖数=原图G的顶点数-二分图的最大匹配数便可以得解。
(可见/article/1569204.html
最小路径覆盖,详见:http://www.cnblogs.com/jianglangcaijin/articles/2746947.html
代码:
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <stdio.h>
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define N 310
using namespace std;
int w

;
int l
;
int visit
,v1,v2;
bool dfs(int x)
{
    int i;
    for(i=1;i<=v2;i++)
    {
        if(!visit[i]&&w[x][i])
        {
            visit[i]=1;
            if(l[i]==0||dfs(l[i]))
            {
                l[i]=x;
                return true;
            }
        }
    }
    return false;
}
int nmatch()
{
    int i,ans=0;
    for(i=1;i<=v1;i++)
    {
        memset(visit,0,sizeof(visit));
        if(dfs(i))
            ans++;
    }
    return ans;
}
int main()
{
    int t,p,q,n,i,j,d;
    int ans;
    scanf("%d",&t);
    {
        while(t--)
        {
            scanf("%d",&p);
            scanf("%d",&n);
            v1=v2=p;
            memset(w,0,sizeof(w));
            memset(l,0,sizeof(l));
            for(i=1;i<=n;i++)
            {
                scanf("%d%d",&q,&d);
                w[q][d]=1;
            }
            ans=nmatch();
            printf("%d\n",p-ans);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: