您的位置:首页 > 其它

POJ 2352 Stars(简单树状数组)

2014-02-22 21:16 477 查看
什么是树状数组在这里就不说了啊,这里有解释了啊。http://blog.csdn.net/fulongxu/article/details/19701281

就是一个模版题目,直接套模版都可以过。先建数组,再求和。

由于y坐标是升序的且坐标不重复,所以在星星A后面输入的星星的x,y坐标不可能都小于等于星星A。假如当前输入的星星为(3,3),易得我们只需要去找树状数组中小于等于3的值就可以了。

Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29336 Accepted: 12829
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 50000;

using namespace std;

int c[maxn];
int vis[maxn];

int lowbit(int x)
{
return x&(-x);
}

void add(int x)
{
while(x < maxn)
{
c[x]++;
x += lowbit(x);
}
}

int sum(int x)
{
int cnt = 0;
while(x > 0)
{
cnt += c[x];
x -= lowbit(x);
}
return cnt;
}

int main()
{
int n;
while(~scanf("%d",&n))
{
int x, y;
memset(vis, 0 , sizeof(vis));
for(int i = 0; i < n; i++)
{
scanf("%d %d",&x, &y);
x++;
y++;
vis[sum(x)]++;
add(x);
}
for(int i = 0; i < n; i++)
cout<<vis[i]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj