您的位置:首页 > 其它

poj 2352 Stars(树状数组)

2017-04-14 14:44 211 查看

Stars

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

题意:如果一个点的左下方有n个点,那么他就属于leveln,比如说点(1,1)的左下方有0个点,那么他就属于level0了。最后分别输出level0有多少个,level1有多少个………level(n-1)有多少个(题目的输入是按如果y轴相等则按x轴升序,否则按y轴升序输入)

思路:基本的树状数组操作,注意坐标有可能为0,所以加的时候把每一位都加1

代码:

#include<stdio.h>
#include<string.h>

#define maxn 32005

int a[maxn],level[maxn];
int n,m;
struct node
{
int x,y,pos;
} q[maxn];

int lowbit(int x)
{
return x&-x;
}

void add(int i,int x)
{
while(i<=32001
4000
)//注意这里
{
a[i]+=x;
i+=lowbit(i);
}
}

int getsum(int i)
{
int sum=0;
while(i)
{
sum+=a[i];
i-=lowbit(i);
}
return sum;
}

int main()
{
scanf("%d",&n);
int x,y;
for(int i=0; i<n; ++i)
{
scanf("%d%d",&x,&y);
++level[getsum(x+1)];
add(x+1,1);
}
for(int i=0; i<n; ++i)
printf("%d\n",level[i]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: