您的位置:首页 > 其它

POJ 2352 Stars(树状数组)

2014-05-02 11:31 330 查看
Stars

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 30496Accepted: 13316
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the
star number 5 is equal to 3 (it's formed by three stars with a numbers
1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At
this map there are only one star of the level 0, two stars of the level
1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input

The
first line of the input file contains a number of stars N
(1<=N<=15000). The following N lines describe coordinates of stars
(two integers X and Y per line separated by a space,
0<=X,Y<=32000). There can be only one star at one point of the
plane. Stars are listed in ascending order of Y coordinate. Stars with
equal Y coordinates are listed in ascending order of X coordinate.

Output

The
output should contain N lines, one number per line. The first line
contains amount of stars of the level 0, the second does amount of stars
of the level 1 and so on, the last line contains amount of stars of the
level N-1.
Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

初识树状数组,很有帮助,基本结构,算法,操作,

/*
poj stars 2352
by zhh
*/
#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxx 35010
#define maxl 32010
int c[maxx];//树状数组c
int level[maxl];
int lowbit(int x)//c[i]=a[i-2^k+1]中k的值2^k
{
return x&(-x);
}
void add(int x,int val)//添加数组值
{
while(x<maxx)
{
c[x]+=val;
x+=lowbit(x);
}
}
int getsum(int x)
{
int sum=0;
for(int i=x;i>0;i-=lowbit(i))
{
sum+=c[i];
}
return sum;
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
memset(c,0,sizeof(c));
memset(level,0,sizeof(level));
for(int i=0;i<n;i++)
{
int x,y;
scanf("%d %d",&x,&y);
x++;//避免x为0的情况
int leve=getsum(x);
level[leve]++;
add(x,1);
}
for(int i=0;i<n;i++)
printf("%d\n",level[i]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: