您的位置:首页 > 其它

POJ 1195 Mobile phones(二维树状数组)

2014-02-26 15:22 429 查看
题意很清晰就是对一个矩阵进行区间的更新与查询,代码写起来很简单。就是树状数组存贮方式的原理得知道,感觉树状数组,很强大啊、芳姐给指点的思路,每一个数组元素的子树是这个下标二进制的从右向左第一个1表示之前的元素。比如8->1000所以它可以由0100(4),0110(6),0111(7),组成。详解看之前的博客:http://blog.csdn.net/fulongxu/article/details/19701281

裸的二维树状数组,注意输出是:ans = sum (x2+1,y2+1) - sum(x2+1,y1) - sum(x1,y2+1) + sum (x1,y1);减去多于的然后加上减过两次的。

Mobile phones

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 13686 Accepted: 6348
Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The
number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with
the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter
integers according to the following table. 



The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and
0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 

Cell value V at any time: 0 <= V <= 32767 

Update amount: -32768 <= A <= 32767 

No of instructions in input: 3 <= U <= 60002 

Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3

Sample Output
3
4

#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 1500;

using namespace std;

int c[maxn][maxn];
int n;

int lowbit(int x)
{
return x&(-x);
}

void add(int x, int y, int ad)
{
for(int i = x; i <= n; i+= lowbit(i))
for(int j = y; j<= n; j += lowbit(j))
c[i][j] += ad;
}

int sum(int x, int y)
{
int cnt = 0;
for(int i = x; i > 0; i -= lowbit(i))
for(int j = y; j > 0; j -= lowbit(j))
cnt += c[i][j];
return cnt;
}

int main()
{
int num;
while(~scanf("%d",&num))
{
if(num == 0)
{
scanf("%d",&n);
memset(c, 0 , sizeof(c));
}
else if(num == 1)
{
int x, y, ad;
scanf("%d %d %d",&x, &y, &ad);
add(x+1, y+1, ad);
}
else if(num == 2)
{
int l, b, r, t;
scanf("%d %d %d %d",&l, &b, &r, &t);
l++; b++; r++; t++;
int ans = sum(r, t)-sum(l-1, t)-sum(r, b-1)+sum(l-1,b-1);
printf("%d\n",ans);
}
else
break;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj