您的位置:首页 > 其它

hdu1102 Constructing Roads (最小生成树 prim 算法)

2013-08-16 20:30 423 查看
Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2


Sample Output
17


最目意思是:求出建立最小的道路长度,使得全部村都连起来,但一开始有的村己经连好了,不须要再建道路!!

#include<stdio.h>
int FN=10000000,s[105],map[105][105],node[105],N,sum;
void set_first()
{
    for(int i=1;i<=N;i++)
    {
        node[i]=FN; s[i]=0;
    }
}
void prim()
{
    int min,n;
    sum=0;s[1]=1; n=1;
    for(int k=2;k<=N;k++)
    {
         for(int i=1;i<=N;i++)
        if(s[i]==0&&node[i]>map
[i])
            node[i]=map
[i];

        min=FN;
        for(int j=1;j<=N;j++)
        if(s[j]==0&&min>node[j])
        {
            min=node[j]; n=j;
        }
        s
=1;sum+=min;
    }
}
int main()
{
    int q,a,b;
    while(scanf("%d",&N)>0)
    {
        set_first();
        for(int i=1;i<=N;i++)
        for(int j=1;j<=N;j++)
        scanf("%d",&map[i][j]);
        scanf("%d",&q);
        while(q--)
       {
        scanf("%d%d",&a,&b);
        map[a][b]=map[b][a]=0;
       }
        prim();
        printf("%d\n",sum);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: