您的位置:首页 > 其它

hdu 1102 Constructing Roads(最小生成树prim)

2015-04-08 16:25 411 查看

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15516 Accepted Submission(s): 5922



Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.



Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.



Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.



Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2




Sample Output
179




Source
kicc

题目分析:

最小生成树模板题

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#define MAX 107

using namespace std;

int cost[MAX];
bool used[MAX];
int mp[MAX][MAX];
int n,m,a,b;

int prim ( )
{
    memset ( cost , 0x3f , sizeof ( cost ));
    memset ( used , false , sizeof ( used ));
    int ret = 0 , minn , pos=1 ,pre;
    scanf ( "%d" , &m );
    for ( int i = 0 ; i < m ; i++ )
    {
        scanf ( "%d%d" , &a , &b );
        mp[a][b] = mp[b][a] = 0;
    }
    for ( int i = 1 ; i < n ; i++ )
    {
        pre = pos;
        used[pre] = true;
        minn = cost[0];
        for ( int j = 1 ; j <= n ; j++ )
            if ( !used[j] && pre != j )
            {
                cost[j] = min ( cost[j] , mp[pre][j] );
                if ( cost[j] < minn )
                    minn = cost[j] , pos = j;
            }
        ret += minn;
    }
    return ret;
}

int main ( )
{
    while ( ~scanf ( "%d" , &n ) )
    {
        for ( int i = 1 ; i <= n ; i++ )
            for ( int j = 1 ; j <= n ; j++ )
                scanf ( "%d" , &mp[i][j] );
        printf ( "%d\n" , prim ());
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: