您的位置:首页 > 其它

hdu 1162 Eddy's picture 最小生成树入门题 Prim+Kruskal两种算法AC

2015-02-22 13:24 696 查看

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7428 Accepted Submission(s): 3770



Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it
can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?



Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.



Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.



Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0




Sample Output
3.41


只需算出一点到其余各点的距离即可。
Prim算法代码:

#include <stdio.h>
#include <math.h>
#include <string.h>
#define MAX 110
#define INF 1000000000

struct Point{
	double x,y;
};
double graph[MAX][MAX] ;
double prim(int n)
{
	bool visited[MAX];
	memset(visited,false,sizeof(visited));
	double lowcost[MAX] ;
	int closest[MAX] ;
	for(int i = 0 ; i < n ; ++i)
	{
		lowcost[i] = graph[0][i] ;
		closest[i] = 0 ;
	}
	lowcost[0] = 0.0 ;
	visited[0] = false ;
	for(int i = 0 ; i < n ; ++i)
	{
		int min = INF , index = 0 ;
		for(int j = 0 ; j < n ; ++j)
		{
			if(!visited[j] && lowcost[j]<min)
			{
				index = j ;
				min = lowcost[j] ;
			}
		}
		visited[index] = true ;
		for(int j = 0 ; j < n ; ++j)
		{
			if(!visited[j] && lowcost[j]>graph[index][j])
			{
				lowcost[j] = graph[index][j] ;
				closest[j] = index ;
			}
		}
	}
	double sum = 0.0 ;
	for(int i = 1 ; i < n ; ++i)
	{
		sum += lowcost[i] ;
	}
	return sum ;
}

double distance(const Point &a ,const Point &b)
{
	double x = a.x-b.x , y = a.y-b.y ;
	return sqrt(x*x+y*y);
}

int main()
{
	Point p[MAX];
	int n ;
	while(~scanf("%d",&n))
	{
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%lf%lf",&p[i].x,&p[i].y) ;
		}
		for(int i = 0 ; i < n ; ++i)
		{
			for(int j = 0 ; j <= i ; ++j)
			{
				graph[i][j] = graph[j][i] = distance(p[i],p[j]) ;
			}
		}
		double sum = prim(n) ;
		printf("%.2lf\n",sum) ;
	}
	return 0 ;
}


Kruskal算法代码:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define MAX 110
#define INF 1000000000

using namespace std ;

struct Point{
	double x,y;
};

struct Edge{
	int x , y ;
	double w ;
}edge[MAX*MAX];

bool cmp(const Edge &a ,const Edge &b)
{
	return a.w<b.w ;
}
int f[MAX] ;
void init()
{
	for(int i = 0 ; i < MAX ; ++i)
	{
		f[i] = i ;
	}
}
int find(int x)
{
	int r = x ;
	while(r != f[r])
	{
		r = f[r] ;
	}
	
	int temp ;
	while(x != f[x])
	{
		temp = f[x] ; 
		f[x] = r ;
		x = temp ;
	}
	return r;
}
double kruskal(int m ,int n)
{
	sort(edge,edge+m,cmp) ;
	double lowcost[MAX] ;
	int index = 0 ;
	init() ;
	for(int i = 0 ; i < m ; ++i)
	{
		int fx = find(edge[i].x) , fy = find(edge[i].y) ;
		if(fx != fy)
		{
			lowcost[index++] = edge[i].w ;
			f[fx] = fy ;
		} 
	}
	double sum = 0 ;
	for(int i = 0 ; i < n-1 ; ++i)
	{
		sum += lowcost[i] ;
	}
	return sum ;
}

double dis(const Point &a ,const Point &b)
{
	double x = a.x-b.x , y = a.y-b.y ;
	return sqrt(x*x+y*y);
}

int main()
{
	Point p[MAX];
	int n ;
	while(~scanf("%d",&n))
	{
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%lf%lf",&p[i].x,&p[i].y) ;
		}
		int index = 0 ;
		for(int i = 0 ; i < n ; ++i)
		{
			for(int j = 0 ; j <= i ; ++j)
			{
				edge[index].x = i , edge[index].y = j ;
				edge[index].w = dis(p[i],p[j]) ;
				index++ ;
			}
		}
		double sum = kruskal(index , n) ;
		printf("%.2lf\n",sum) ;
	}
	return 0 ;
}


与君共勉
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: