您的位置:首页 > 其它

HDU1701,求后序,递归

2020-05-11 04:10 169 查看

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
Output
For each test case print a single line specifying the corresponding postorder sequence.
Sample Input
9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6
Sample Output
7 4 2 8 9 5 6 3 1

void dfs(int l1,int r1,int l2,int r2)
{
if(l1>r1)
return ;
int i,k=-1;
for(i=l2;a[i]!=b[l1];i++);
dfs(l1+1,r1-r2+i,l2,i-1);
dfs(r1-r2+i+1,r1,i+1,r2);
if(flag)
printf(" ");
printf("%d",b[l1]);
flag=1;

}

先传入(l1,r1,l2,r2); l1 左 i 根 r1 右 (0,8,0 ,8)
a[3]=b[0],i=3;
dfs(1,3,0,2) 1 3 为 先序中左子树得区间 为 2 4 7,0,2 为中序中左子树得区间 为 4 7 2;
a[2]=b[1]=2 i=2, dfs(2,3,0,1),继续找左子树中得根位置,判断左子树中得左区间。。。因为后序为,左右根,所以遍历完成后 倒着输出根,
即 b[l1];

#include<stdio.h>
#include<string.h>
int a[1002],b[1002],flag;
void dfs(int l1,int r1,int l2,int r2)
{
if(l1>r1)
return ;
int i,k=-1;
for(i=l2;a[i]!=b[l1];i++);
dfs(l1+1,r1-r2+i,l2,i-1);
dfs(r1-r2+i+1,r1,i+1,r2);
if(flag)
printf(" ");
printf("%d",b[l1]);
flag=1;

}int main()
{
int n,i;
while(~scanf("%d",&n))
{
flag=0;
for(i=0;i<n;i++)
scanf("%d",&b[i]);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
dfs(0,n-1,0,n-1);
printf("\n");
}
return 0;
}

Starry_Sky_Dream 原创文章 50获赞 4访问量 2325 关注 私信
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: