您的位置:首页 > 其它

PAT(排序,cin巨坑)——1055. The World’s Richest

2019-01-17 20:31 274 查看
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/86530867

1055. The World’s Richest

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) – the total number of people, and K (<=103) – the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) – the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output “None”.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目大意:

给定年龄区间,输出资产从大到小的n个人。

题目解析:

先将人按照资产从大到小排序,每次从前往后选取年龄符合要求的人。这题一开始有一个样例超时了,在网上搜了一下,发现不止我一个人出现这个问题,找到成功ac的代码,对比一下,他io操作用的是scanf,printf,而我图省事用了cin cout,改成scanf,printf果然就过了。这对我来讲也是一个小教训,以后io操作坚决不用cin cout。

具体代码:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
char name[9];
int age;
int money;
}P[100100];
bool cmp(node a,node b){
if(a.money!=b.money)
return a.money>b.money;
else if(a.age!=b.age)
return a.age<b.age;
else
return strcmp(a.name,b.name)<0;
}
int main()
{
int n,k;
scanf("%d%d",&n,&k);
for(int i=0;i<n;i++){
scanf("%s%d%d",&P[i].name,&P[i].age,&P[i].money);
}
sort(P,P+n,cmp);
for(int i=1;i<=k;i++){
printf("Case #%d:\n",i);
int num,low,high,flag=1;
scanf("%d %d %d", &num, &low, &high);
for(int j=0;j<n&&num>0;j++){
if(P[j].age>=low&&P[j].age<=high){
printf("%s %d %d\n",P[j].name,P[j].age,P[j].money);
num--;
flag=0;
}
}
if(flag)
printf("None\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: