您的位置:首页 > 编程语言 > C语言/C++

PAT_1055: The World's Richest

2013-07-31 20:44 337 查看
Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths
of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines
follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines
of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format
Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must
be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In
case no one is found, output "None".

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

备注:题目很像一个数据库查询,对效率的要求比较高。刚开始先对age进行统计,再排序输出,结果case 2超时;后直接对整个数组排序然后输出,结果case 1超时最后AC的方法是:先对整个数组进行排序,然后统计各年龄的人数,过滤那些各年龄100名后的人(因为M<=100,他们永远不可能被输出),用另一数组进行标记是否要放弃,最后遍历该数组即可,节省了时间。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

#define MAXAGE 201
#define MAXPERSON 100000

typedef struct person
{
char name[20];
int age;
int worth;
}PERSON;

PERSON Person_list[MAXPERSON];

int compare(const void *a,const void *b)
{
PERSON *p1 = (PERSON *)a;
PERSON *p2 = (PERSON *)b;

if(p1->worth==p2->worth && p1->age==p2->age)
return strcmp(p1->name,p2->name);
if(p1->worth==p2->worth)
return p1->age-p2->age;
return p2->worth-p1->worth;
}

int main()
{
int n,k;
int m,Amin,Amax;
int i,j;
int ageCount[MAXAGE]={0};
int output[MAXPERSON];

scanf("%d %d",&n,&k);
for(i=0;i<n;i++)
scanf("%s %d %d",Person_list[i].name,&Person_list[i].age,&Person_list[i].worth);

qsort(Person_list,n,sizeof(PERSON),compare);

// count the number of people of each age and abandon those who are ranked after 100
// flag the sorted array
int bound = 0;
for(i=0;i<n;i++)
{
if(++ageCount[Person_list[i].age]<=100)
output[bound++]=i;
}

for(i=1;i<=k;i++)
{
scanf("%d %d %d",&m,&Amin,&Amax);
printf("Case #%d:\n",i);
int countM=0;
for(j=0;j<bound;j++)
{
PERSON p = Person_list[output[j]];
if(p.age>=Amin && p.age<=Amax && countM<m)
{
printf("%s %d %d\n", p.name,p.age,p.worth);
countM++;
}
if(countM==m)
break;
}
if(countM==0)
printf("None\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息