您的位置:首页 > 其它

PAT(排序)——1075 PAT Judge (25 分)

2019-01-18 15:52 288 查看
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/86541410

1075 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10
​4
​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10
​5
​​ ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained
where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

题目大意:

给用户按照pat成绩排名。

题目解析:

结构体排序,业务逻辑比较复杂。

具体代码:

#include<iostream>
#include<algorithm>
using namespace std;
struct node{
int rank;
int id;
int flag;
int isshow;
int total;
int s[10];
int perfect;
node(){
flag=0;
total=0;
perfect=0;
isshow=0;
for(int i=0;i<10;i++)
s[i]=-2;
}
}A[10010];
int p[10];
bool cmp(node a,node b){
if(a.flag!=b.flag)
return a.flag>b.flag;
else if(a.total!=b.total)
return a.total>b.total;
else if(a.perfect!=b.perfect)
return a.perfect>b.perfect;
else
return a.id<b.id;
}
int main()
{
int n,k,m;
scanf("%d%d%d",&n,&k,&m);
for(int i=1;i<=k;i++)
scanf("%d",&p[i]);
for(int i=0;i<m;i++){
int uid,pid,score;
scanf("%d%d%d",&uid,&pid,&score);
A[uid].flag=1;
A[uid].id=uid;
if(score>=0)
A[uid].isshow=1;
if(A[uid].s[pid]<score){
if(score!=-1){
if(A[uid].s[pid]==-2||A[uid].s[pid]==-1)
A[uid].total=A[uid].total+score;
else
A[uid].total=A[uid].total-A[uid].s[pid]+score;
}

A[uid].s[pid]=score;
if(score==p[pid])
A[uid].perfect++;
}
}
sort(A,A+10010,cmp);
A[0].rank=1;
int count=1;
for(int i=1;i<10010;i++){
if(A[i].flag==0) break;
count++;
if(A[i].total==A[i-1].total)
A[i].rank=A[i-1].rank;
else
A[i].rank=i+1;
}
for(int i=0;i<count;i++){
if(A[i].isshow==0) continue;
printf("%d %05d %d",A[i].rank,A[i].id,A[i].total);
for(int j=1;j<=k;j++){
printf(" ");
if(A[i].s[j]==-2)
printf("-");
else if(A[i].s[j]==-1)
printf("0");
else
printf("%d",A[i].s[j]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: