您的位置:首页 > 其它

PAT(排序)——1025 PAT Ranking (25 分)

2019-01-17 16:18 387 查看
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/86526568

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目大意:

给出每个考场学生的成绩,求出学生总排名和每个考场的排名。

题目解析:

用一个一维数组存储所有的学生,用sort函数求出其排名。

具体代码:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct node{
long long id;
int score;
int final_rank;
int location;
int local_rank;
}A[50010];
bool cmp0(node a,node b){
if(a.score!=b.score)
return a.score>b.score;
else
return a.id<b.id;
}
int main()
{
int start=-1,end=-1,n;
cin>>n;
for(int i=1;i<=n;i++){
int k;
cin>>k;
start=end+1;
end=end+k;
for(int j=start;j<=end;j++){
cin>>A[j].id>>A[j].score;
A[j].location=i;
}
sort(A+start,A+end+1,cmp0);
A[start].local_rank=1;
for(int j=start+1;j<=end;j++){
if(A[j].score==A[j-1].score)
A[j].local_rank=A[j-1].local_rank;
else
A[j].local_rank=j-start+1;
}
}
sort(A,A+end+1,cmp0);
A[0].final_rank=1;
for(int j=1;j<=end;j++){
if(A[j].score==A[j-1].score)
A[j].final_rank=A[j-1].final_rank;
else
A[j].final_rank=j+1;
}
sort(A,A+end+1,cmp0);
cout<<end+1<<endl;
for(int i=0;i<=end;i++){
printf("%013lld %d %d %d\n",A[i].id,A[i].final_rank,A[i].location,A[i].local_rank);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: