您的位置:首页 > 其它

1117. Eddington Number(25)

2018-03-06 15:57 369 查看
1117. Eddington Number(25)

时间限制 250 ms 内存限制 65536 kB 代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (<=N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10

6 7 6 9 3 10 8 2 7 8

Sample Output:

6

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>

using namespace std;
const int MaxN = 100010;
int main() {
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG
std::ios::sync_with_stdio(false);

int n, data[MaxN]; cin >> n;
for (int i = 1; i <= n; ++i)cin >> data[i];

int ans = 0;
sort(data + 1, data + n + 1, [](int a, int b) {return a > b; });
for (int i = 1; i <= n && data[i] > i; ++i)++ans;
cout << ans;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat甲级 1117