您的位置:首页 > 其它

1117. Eddington Number(25)

2017-08-07 20:28 225 查看
British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (<=N).


Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.


Output Specification:


For each case, print in a line the Eddington number for these N days.

Sample Input:
10
6 7 6 9 3 10 8 2 7 8


Sample Output:
6


#include<iostream>
#include<algorithm>
using namespace std;
int a[100004];
bool cmp(int a,int b)
{
return a>=b;
}
int main()
{
int n;
cin>>n;
for (int i=0;i<n;i++)
cin>>a[i];
sort(a,a+n,cmp);
for (int  i=0;i<n;i++)
{
if (a[i]<=(i+1))
{
cout<<i;
return 0;
}
}
cout<<n;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: