您的位置:首页 > 其它

1045. Favorite Color Stripe (30)

2018-03-06 20:00 239 查看
1045. Favorite Color Stripe (30)

时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6

5 2 3 1 5 6

12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <cstring>

using namespace std;
const int MaxN = 10010;
const int MaxC = 210;
int A[MaxN],dp[MaxN];
int hashTable[MaxC], num = 0;

int main() {
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG
std::ios::sync_with_stdio(false);

int n,x; cin >> x >> n;
memset(hashTable, -1, MaxC);
for (int i = 0; i < n; ++i) {
cin >> x;
hashTable[x] = i;
}

cin >> n;
for (int i = 0; i < n; ++i) {
cin >> x;
if (hashTable[x] >= 0) A[num++] = hashTable[x];
}

int res = -1;
for (int i = 0; i < num; ++i) {
dp[i] = 1;
for (int j = 0; j < i; ++j) {
if (A[j] <= A[i] && dp[j] >= dp[i])dp[i] = dp[j] + 1;
}
res = max(res, dp[i]);
}

cout << res;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat甲级 1045