您的位置:首页 > 其它

1117. Eddington Number(25)

2018-01-15 08:16 369 查看


1117. Eddington Number(25)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E
was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (<=N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.
Sample Input:
10
6 7 6 9 3 10 8 2 7 8

Sample Output:
6


代码实现:#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
int n;
int day[100005];
cin>>n;
int e=n,ans=0;
for(int i=0;i<n;i++)
{
cin>>day[i];
}
while(e>0)
{
int count=n;
for(int j=0;j<n;j++)
{
if(day[j]<=e)
{
count--;
}
if(count<e)
{
break;
}
}
if(count>=e)
{
ans=e;
break;
}
e--;
}
printf("%d",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: