您的位置:首页 > 其它

小白算法练习 PAT Consecutive Factors 暴力|暴力中比较好的题目

2018-03-01 15:40 309 查看
Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number
of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing
order, and 1 is NOT included.
Sample Input:
630

Sample Output:
3
5*6*7

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
long N,sum=0;scanf("%d",&N);
int res,c;
int maxm=0;
for(int i=2;i<=sqrt(N);i++)
{
int t=i;c=0;
  sum=N;
while(sum%t==0)
{
sum=sum/t;
t=t+1;
c=c+1;
}
if(t-i>maxm)
{
res=i;
maxm=c;
}

if(maxm==0)
{
cout<<1<<endl;
cout<<N<<endl;
return 0;
}
printf("%d\n",maxm);
for(int i=res;i<res+maxm;i++)
{
cout<<i;
if(i!=res+maxm-1)
{
cout<<"*";
}
}
cout<<endl;
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: