您的位置:首页 > 理论基础 > 数据结构算法

C语言 链表 数据结构实验之链表一:顺序建立链表

2018-01-19 21:21 519 查看


数据结构实验之链表一:顺序建立链表


Problem Description

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。


Input

第一行输入整数的个数N;

第二行依次输入每个整数。


Output

输出这组整数。


Example Input

8
12 56 4 6 55 15 33 62



Example Output

12 56 4 6 55 15 33 62


#include <stdio.h>
#include <stdlib.h>
struct sdut
{
int data;
struct sdut *next;
};
int main()
{
struct sdut *head, *q, *p, *t;
int i, n, a;
scanf("%d", &n);
head = NULL;
for(i = 1; i <= n; i++)
{
scanf("%d", &a);
p = (struct sdut *) malloc (sizeof (struct sdut));
p -> data = a;
p -> next = NULL;
if(head == NULL)
head = p;
else
q -> next = p;
q = p;
}
t = head;
while(t != NULL)
{
if(t -> next == NULL)
{
printf("%d", t -> data);
}
else
printf("%d ", t -> data);
t = t -> next;
}
return 0;
}


或者

#include <stdio.h>
#include <stdlib.h>
struct sdut
{
int data;
struct sdut *next;
};
int main()
{
int n;
struct sdut *head, *p, *tail;
head = (struct sdut*)malloc(sizeof(struct sdut));
head -> next = NULL;
tail= head;
scanf("%d", &n);
int i;
for(i = 0; i < n; i++)
{
p = (struct sdut*)malloc(sizeof(struct sdut));
scanf("%d", &p -> data);
p -> next = NULL;
tail -> next = p;
tail = p;
}
p = head -> next;
while(p)
{
if(p -> next)
printf("%d ", p -> data);
else
printf("%d\n", p -> data);
p = p -> next;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: