您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表一:顺序建立链表

2014-01-17 01:53 363 查看

题目描述

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。

输入

第一行输入整数的个数N;

第二行依次输入每个整数。

输出

输出这组整数。

示例输入

8
12 56 4 6 55 15 33 62


示例输出

12 56 4 6 55 15 33 62

#include<stdio.h>   
#include<stdlib.h>   
struct node   
{   
    int date;   
    struct node *next;   
};   
struct node *head=NULL,*p,*q;   
int main()   
{   
    int n,flag,k=1;   
    scanf("%d",&n);   
    while(n--)   
    {   
        if((p=(struct node*)malloc(sizeof(struct node)*1))==NULL)   
            return 1;   
        scanf("%d",&p->date);   
        p->next=NULL;   
        if(head==NULL)   
        {   
           
            head=p;   
            q=p;   
        }   
        else  
        {   
                   q->next=p;   
                   q=q->next;   
                     
           
        }   
    }   
           
            q=head;   
            while(q!=NULL)   
            {   
                printf("%d",q->date);   
                if(q->next!=NULL)   
                printf(" ");   
                q=q->next;   
            }   
            printf("\n");   
       
            return 0;   
 }   
    
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: