您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表一:顺序建立链表

2016-09-02 21:32 369 查看


Problem Description

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。


Input

第一行输入整数的个数N;

第二行依次输入每个整数。


Output

输出这组整数。


Example Input

8
12 56 4 6 55 15 33 62



Example Output

12 56 4 6 55 15
4000
33 62

#include <stdio.h>

#include <stdlib.h>

struct node

{

    int data;

    struct node *next;

}*head,*tail,*p;

void print(struct node *h)

{

    struct node *p=h->next;

    while(p!=NULL)

    {

        printf("%d ",p->data);

        p=p->next;

    }

}

struct node *create(int n)

{

    int i;

    head=(struct node *)malloc(sizeof(struct node));

    head->next=NULL;

    tail=head;

    for(i=1;i<=n;i++)

    {

        p=(struct node *)malloc(sizeof(struct node));

        scanf("%d",&p->data);

        p->next=NULL;

        tail->next=p;

        tail=p;

    }

    return head;

}

int main()

{

    int n;

    scanf("%d",&n);

    struct node *h;

    h=create(n);

    print(h);

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: