您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表一:顺序建立链表

2015-02-02 20:46 295 查看
Description

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。

Input

第一行输入整数的个数N;

第二行依次输入每个整数。

Output

输出这组整数。

Sample Input

8
12 56 4 6 55 15 33 62


Sample Output

12 56 4 6 55 15 33 62


#include <stdio.h>
#include <stdlib.h>
struct node
{
int date;
struct node *next;
};
int main()
{
int i,n;
struct node *tail,*p,*head;
while(~scanf("%d",&n))
{
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
p->next=NULL;
scanf("%d",&p->date);
tail->next=p;
tail=p;
}
p=head->next;
while(p)
{
if(p->next!=NULL)
printf("%d ",p->date);
else
printf("%d\n",p->date);
p=p->next;
}
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: