您的位置:首页 > 理论基础 > 数据结构算法

[SDUT](2116)数据结构实验之链表一:顺序建立链表 ---链式存储(线性表)

2017-09-08 14:41 816 查看


数据结构实验之链表一:顺序建立链表

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic Discuss


Problem Description

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。


Input

第一行输入整数的个数N;

第二行依次输入每个整数。


Output

输出这组整数。


Example Input

8
12 56 4 6 55 15 33 62



Example Output

12 56 4 6 55 15 33 62




AC代码:
#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
typedef struct Node
{
int data;
struct Node *next;
}node;
void creatLinklist(node * &L,int n)
{
node *s;
node *now;
L=(node *)malloc(sizeof(node));
now = L;
int d;
for(int i=0;i<n;i++)
{
scanf("%d",&d);
s = (node *)malloc(sizeof(node));
s->data = d;
now->next = s;
now = s;
}
now->next = NULL;
}
void print(node *L)
{
node *p = L->next;
while(p!=NULL)
{
if(p->next!=NULL)
printf("%d ",p->data);
else
printf("%d\n",p->data);
p = p->next;
}
}
int main()
{
node *L;
int n;
scanf("%d",&n);
creatLinklist(L,n);
print(L);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: