您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树七:叶子问题

2017-11-12 10:23 113 查看
数据结构实验之二叉树七:叶子问题

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic Discuss

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

Input

输入数据有多行,每一行是一个长度小于50个字符的字符串。

Output

按从上到下从左到右的顺序输出二叉树的叶子结点。

Example Input

abd,,eg,,,cf,,,

xnl,,i,,u,,

Example Output

dfg

uli

Hint

Author

xam

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int MAX = 205;

typedef struct node
{
char data;
struct node *cl, *cr;
} tree, *ptree;

char str[MAX];
int i;
void gettreepre(ptree &root)
{
char ch;
ch = str[i++];
if (ch == ',')
{
root = NULL;
}
else
{
root = new tree;
root->data = ch;
gettreepre(root->cl);
gettreepre(root->cr);
}
}

void showyezi(ptree root)
{
if (root == NULL)
{
cout << endl;
return;
}
ptree arr[MAX];
int front, rear;
front = rear = 0;
arr[rear++] = root;
while (front < rear)
{
if (arr[front]->cl == NULL && arr[front]->cr == NULL)
cout << arr[front]->data;
if (arr[front]->cl != NULL)
arr[rear++] = arr[front]->cl;
if (arr[front]->cr != NULL)
arr[rear++] = arr[front]->cr;
front++;
}
cout << endl;
}
int main()
{
while (cin >> str)
{
i = 0;
ptree root = NULL;
gettreepre(root);
showyezi(root);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: