您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树七:叶子问题

2016-08-09 08:38 176 查看


数据结构实验之二叉树七:叶子问题



Time Limit: 1000MS Memory limit: 65536K


题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。


输入

 输入数据有多行,每一行是一个长度小于50个字符的字符串。


输出

 按从上到下从左到右的顺序输出二叉树的叶子结点。


示例输入

abd,,eg,,,cf,,,
xnl,,i,,u,,



示例输出

dfg
uli



提示

 


来源

 xam


示例程序

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
int data;
struct node *lchild,*rchild;
}node;
int k;
node *creat(char str[])
{
k++;
node *root;
if(str[k] == ',')
root = NULL;
else
{
root= (node *)malloc(sizeof(node));
root->data = str[k];
root->lchild = creat(str);
root->rchild = creat(str);
}
return root;
}
void layer(node *root)
{
int base = 0,top = 0;
node *s[1000];
s[top++] = root;
while(top > base)
{
if(s[base])
{
root = s[base];
if(root->lchild)
{
s[top++] = root->lchild;
}
if(root->rchild)
{
s[top++] = root->rchild;
}
if(!root->lchild && !root->rchild)
{
printf("%c",root->data);
}
}
base++;
}
}
int main()
{
node *root;
char str[1000];
while(~scanf("%s",str))
{
k = -1;
root = creat(str);
layer(root);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构 编码