您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树七:叶子问题

2015-11-08 11:50 232 查看

数据结构实验之二叉树七:叶子问题

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

输入

输入数据有多行,每一行是一个长度小于50个字符的字符串。

输出

按从上到下从左到右的顺序输出二叉树的叶子结点。

示例输入

abd,,eg,,,cf,,,
xnl,,i,,u,,


示例输出

dfg
uli


提示

来源

xam

示例程序

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char a[100];
int l1;
struct node
{
int data;
struct node *lchild,*rchild;
};
struct node *creat()
{
struct node  *root;
char c;
c=a[l1++];
if(c==',')
return NULL;
else
{
root=(struct node *)malloc(sizeof(struct node));
root->data=c;
root->lchild=creat();
root->rchild=creat();

}
return root;
}
void cengci(struct node *root)
{
int out=0,in=0;
struct node *q[100];
q[in++]=root;
while(in>out)
{
if(q[out])
{
if(q[out]->lchild==NULL&&q[out]->rchild==NULL)
printf("%c",q[out]->data);
q[in++]=q[out]->lchild;
q[in++]=q[out]->rchild;
}
out++;
}
}
int main()
{
int i,j,n,m,k,t;
struct node *root;
while(scanf("%s",a)!=EOF)
{
l1=0;
root=(struct node *)malloc(sizeof(struct node));
root=creat();
cengci(root);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: