您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树七:叶子问题

2017-11-10 21:42 113 查看
数据结构实验之二叉树七:叶子问题

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

Input

输入数据有多行,每一行是一个长度小于50个字符的字符串。

Output

按从上到下从左到右的顺序输出二叉树的叶子结点。

Example Input

abd,,eg,,,cf,,,

xnl,,i,,u,,

Example Output

dfg

uli

Hint

Author

xam

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
char data;
struct node *lchild,*rchild;
};
char a[55];
int i;
struct node *creat()
{
struct node *t;
char e;
e = a[i++];
if(e==',')return t = NULL;
else
{
t = (struct node *)malloc(sizeof(struct node));
t -> data = e;
t -> lchild = creat();
t -> rchild = creat();
}
return t;
}
void output(struct node *t)
{
int i = 0,j = 1;
int flag;
struct node *b[55];//建立结构体数组
b[0] = t;
while(i < j)
{
if(b[i])
{
flag = 0;
b[j++] = b[i] -> lchild;
if(b[i]->lchild==NULL)flag++;//若结点不为空,则下一个数组元素存左孩子
b[j++] = b[i] -> rchild;//存右孩子的地址;
if(b[i]->rchild==NULL)flag++;
if(flag==2)printf("%c",b[i]->data);//若左右孩子都为空,则为叶子,输出次结点
}
i++;
}
}
int main()
{
while(~scanf("%s",a))
{
struct node *T;
i = 0;
T = creat();
output(T);
printf("\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构 二叉树