您的位置:首页 > 其它

POJ2155--Matrix::二维树状数组

2017-11-05 17:04 246 查看

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).

2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1


Sample Output

1
0
0
1


CODE:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int _t;
int n,m;
char c[2];
int x1,y1,x2,y2;
int cnt[1005][1005];

inline int LowBit(int x)
{
return x & (-x);
}

inline void Add(int x,int y)
{
for(int i=x;i<=n;i+=LowBit(i))//一定要用for
{
for(int j=y;j<=n;j+=LowBit(j))
{
cnt[i][j]++;
}
}
return;
}

inline int GetSum(int x,int y)
{
int s = 0;
for(int i=x;i>0;i-=LowBit(i))
{
for(int j=y;j>0;j-=LowBit(j))
{
s += cnt[i][j];
}
}
return s;
}

int main()
{
scanf("%d",&_t);
while(_t--)
{
memset(cnt,0,sizeof(cnt));
scanf("%d%d",&n,&m);
while(m--)
{
scanf("%s",c);
// cout<<c<<endl;
if(c[0] == 'C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
Add(x1,y1);
Add(x2+1,y2+1);
Add(x1,y2+1);
Add(x2+1,y1);
}
else
{
scanf("%d%d",&x1,&y1);
printf("%d\n",GetSum(x1,y1)%2);
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: