您的位置:首页 > 其它

PAT 甲级 1100. Mars Numbers (20)

2017-10-06 23:20 351 查看
People on Mars count their numbers with base 13:

Zero on Earth is called "tret" on Mars.

The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.

For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth
and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (< 100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.
Sample Input:
4
29
5
elo nov
tam

Sample Output:
hel mar
may
115
13


#include <iostream>
#include <cstdio>
#include <string>
#include <map>

using namespace std;

string unitDight[13]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
string tenDight[13]={"tret","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};
string numToStr[170];
map<string,int> strToNum;

void init(){
for(int i=0;i<13;i++){
numToStr[i]=unitDight[i];
strToNum[unitDight[i]]=i;
numToStr[i*13]=tenDight[i];
strToNum[tenDight[i]]=i*13;
}
for(int i=1;i<13;i++){
for(int j=1;j<13;j++){
string str=tenDight[i]+" "+unitDight[j];
numToStr[i*13+j]=str;
strToNum[str]=i*13+j;
}
}
}
int main()
{
init();
int n;
cin>>n;
getchar();
while(n--){
char str[1010];
gets(str);
if(str[0]>='0'&&str[0]<='9'){
int num=0;
sscanf(str,"%d",&num);
cout<<numToStr[num]<<endl;
}else{
cout<<strToNum[str]<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: