您的位置:首页 > 其它

PAT 1100. Mars Numbers (20)

2016-02-29 12:26 369 查看


1100. Mars Numbers (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

People on Mars count their numbers with base 13:

Zero on Earth is called "tret" on Mars.

The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.

For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth
and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (< 100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.
Sample Input:
4
29
5
elo nov
tam

Sample Output:
hel mar
may
115
13


这道题一方面是考进制转换,另一方面是考察映射,需要注意的是诸如13这样的“整数”翻译成火星语应当是“tam”,后面不跟“0”,也就是说不跟“tret”。

代码如下:

#include <iostream>
#include <string>
#include <sstream>
#include <vector>
#include <cstdlib>
using namespace std;
string lower[13]={"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string higher[13]={"tret","tam", "hel", "maa", "huh", "tou", "kes", "hei","elo", "syy", "lok", "mer", "jou"};
string convertEtoM(int x)
{
int high = x/13;
int low = x%13;
string result="";
if(high > 0){
result = higher[high] + " ";
if(low == 0){
return higher[high];
}
}
result += lower[low];
return result;
}
int main(void)
{
int N,i;
cin>>N;
getchar();
while(N--){
string inputString;
getline(cin,inputString);
if(inputString[0]>='0' && inputString[0]<='9')			//if it's earth number
cout<<convertEtoM(atoi(inputString.c_str()))<<endl;
else{
istringstream is(inputString);
vector<string> splitString;
splitString.clear();
while(is>>inputString)
splitString.push_back(inputString);
if(splitString.size() < 2){
for(i = 0 ; i < 13; i++)
if(lower[i] == splitString[0]){
cout<<i<<endl; break;
}
if(i >= 13){
for(i = 0; i < 13; i++)
if(higher[i] == splitString[0]){
cout<<i*13<<endl; break;
}
}
}
else{
int result = 0;
for(i = 0; i < 13; i++)
if(higher[i] == splitString[0]){
result += 13 * i; break;
}
for(i = 0; i < 13; i++)
if(lower[i] == splitString[1]){
result += i; break;
}
cout<<result<<endl;
}
}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: