您的位置:首页 > 其它

【PAT】1100. Mars Numbers (20)

2015-10-08 20:21 387 查看
People on Mars count their numbers with base 13:

Zero on Earth is called "tret" on Mars.

The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.

For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth
and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (< 100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.
Sample Input:
4
29
5
elo nov
tam

Sample Output:
hel mar
may
115
13
注意点:
(1)使用getline(cin,string)的方法来输入整行整行字符串,包括中间的空格;记得要先用getchar()吃掉回车;
(2)使用stringstream的方法对字符串拆分;注意stringstream要清空;
(3)使用map将火星文与数字进行对应;
(4)数字最大为168,所以输入的火星文最多是俩个单词组成的;

#include<iostream>
#include<vector>
#include<string>
#include<sstream>
#include<map>
using namespace std;

string low[] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
string high[] = {"tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};

int main(){
int N, i;
map<string, int> low2int, high2int;
vector<string> numVec;
stringstream ss;
string str;
for(i=0; i<=12; i++) low2int[ low[i] ] = i;
for(i=1; i<=12; i++) high2int[ high[i-1] ] = i;

cin>>N;
getchar();//注意要吃掉回车

for(i=0; i<N; i++){
getline(cin, str);
if(isdigit(str[0])){
// 输入的是数字
int j, base=13, result = 0;
for(j=0; j<str.size(); j++){
result = result*10 + (str[j]-'0');
}
vector<int> tmpVec;
if(result == 0)
tmpVec.push_back(0);
while(result != 0){
tmpVec.push_back(result%base);
result /= base;
}

if(tmpVec.size() == 1){
cout<<low[tmpVec[0]]<<endl;
}else{
if(tmpVec[0] != 0)
cout<<high[tmpVec[1]-1]<<" "<<low[tmpVec[0]]<<endl;
else
cout<<high[tmpVec[1]-1]<<endl;
}
}else{
// 输入的是火星文
string tmpStr;
ss.clear();
ss.str(str);
numVec.clear();
while(1){
ss>>tmpStr;
if(ss.fail()){
break;
}
numVec.push_back(tmpStr);
}
// 数字最大为169,所以不会numVec.size()不会超过俩个
if(numVec.size() == 1){
if(low2int.find( numVec[0] ) != low2int.end()){
cout<<low2int[numVec[0]]<<endl;
}else if(high2int.find( numVec[0] ) != high2int.end()){
cout<<high2int[numVec[0]]*13<<endl;
}
}else{
cout<<high2int[numVec[0]]*13 + low2int[numVec[1]] <<endl;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  字符串 算法 PAT