您的位置:首页 > 大数据 > 人工智能

【CUGBACM15级BC第30场 B】hdu 5175 Misaki's Kiss again

2017-09-04 21:34 295 查看

Misaki's Kiss again

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1820    Accepted Submission(s): 485
[/align]

[align=left]Problem Description[/align]

After the Ferries Wheel, many friends hope to receive the Misaki's kiss again,so Misaki numbers them
1,2...N−1,N,if
someone's number is M and satisfied the GCD
(N,M
)  equals
to N
XOR M,he
will be kissed again.

Please help Misaki to find all M(1<=M<=N).

Note that:
GCD
(a,b
) means
the greatest common divisor of a
and b.
A
XOR B
means A
exclusive or B
 

[align=left]Input[/align]

There are multiple test cases.

For each testcase, contains a integets N(0<N<=1010
)
 

[align=left]Output[/align]

For each test case,

first line output Case #X:,

second line output k
means the number of friends will get a kiss.

third line contains k
number mean the friends' number, sort them in ascending and separated by a space between two numbers
 

[align=left]Sample Input[/align]

3
5
15

 

[align=left]Sample Output[/align]

Case #1:
1
2
Case #2:
1
4
Case #3:
3
10 12 14

HintIn the third sample, gcd(15,10)=5 and (15 xor 10)=5, gcd(15,12)=3 and (15 xor 12)=3,gcd(15,14)=1 and (15 xor 14)=1

 

题意:给一个n,问有多少个1~n的数满足gcd(n,m)==n^m

思路:一开始想到把n进行整数分解,可是约数不止是质因子啊...比如30,约数可以是15

所以只能暴力枚举约数了,然后每次比较gcd(n,m)==i,m为n^i,i为n的约数,注意枚举到根号n即可O(10^5)可以承受

注意!!注意!!注意!!!

当m的个数为0时,后面依然要输出一个空行!PE了无数次的我如是说道

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

long long gcd(long long a, long long b)
{
return b ? gcd(b, a % b) : a;
}
long long ans[1000000];
int main()
{
long long n;
int t = 1;
while (~scanf("%lld", &n))
{
long long num = 0;
for (long long i = 1; i * i <= n; i++)
{
if (n % i != 0)
{
continue;
}
long long m = n ^ i;
if (m >= 1 && m <= n && gcd(n, m) == i)
{
ans[num++] = m;
}
if (i * i == n || i == 1)
{
continue;
}
m = n ^ (n / i);
if (m >= 1 && m <= n && gcd(n, m) == n / i)
{
ans[num++] = m;
}
}

printf("Case #%d:\n%lld\n", t++, num);
sort(ans, ans + num);
for (int i = 0; i < num; i++)
{
if (i != 0)
{
printf(" ");
}
printf("%lld", ans[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 暴力 数论