您的位置:首页 > 产品设计 > 产品经理

【CUGBACM15级BC第32场 A】hdu 5182 PM2.5

2017-09-07 19:51 375 查看

PM2.5

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1528    Accepted Submission(s): 748
[/align]

[align=left]Problem Description[/align]

Nowadays we use content of PM2.5 to discribe the quality of air. The lower content of PM2.5 one city have, the better quality of air it have. So we sort the cities according to the content of PM2.5 in
asending order.

Sometimes one city’s rank may raise, however the content of PM2.5 of this city may raise too. It means that the quality of this city is not promoted. So this way of sort is not rational. In order to make it reasonable, we come up with a new way to sort the
cityes. We order this cities through the diffrence between twice measurement of content of PM2.5 (first measurement – second measurement) in descending order, if there are ties, order them by the second measurement in asending order , if also tie, order them
according to the input order.
 

[align=left]Input[/align]

Multi test cases (about
100),
every case contains an integer n
which represents there are n
cities to be sorted in the first line.

Cities are numbered through 0 to n−1.

In the next n
lines each line contains two integers which represent the first and second measurement of content of PM2.5

The ith line describes the information of city i−1

Please process to the end of file.

[Technical Specification]

all integers are in the range [1,100]
 

[align=left]Output[/align]

For each case, output the cities’ id in one line according to their order.
 

[align=left]Sample Input[/align]

2
100 1
1 2
3
100 50
3 4
1 2

 

[align=left]Sample Output[/align]

0 1
0 2 1

 

题意:每一个城市有两个权值,先按照第一权值-第二权值降序排序,如果第一权值-第二权值相等,再按照第二权值排序,否则按照输入的顺序排序

思路:直接sort即可,三级排序
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

struct Node
{
int v, w;
int id;
} a[10000];
bool cmp(Node a, Node b)
{
if (a.v == b.v && a.w == b.w)
{
return a.id < b.id;
}
if (a.v == b.v)
{
return a.w < b.w;
}
return a.v > b.v;
}
int main()
{
int n;
while (~scanf("%d", &n))
{
for (int i = 0; i < n; i++)
{
scanf("%d %d", &a[i].v, &a[i].w);
a[i].v -= a[i].w;
a[i].id = i;
}
sort(a, a + n, cmp);
for (int i = 0; i < n - 1; i++)
{
printf("%d ", a[i].id);
}
printf("%d\n", a[n - 1].id);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 结构体排序