您的位置:首页 > 其它

PAT - 甲级 - 1117. Eddington Number(25) (题意理解)

2016-12-08 09:43 429 查看
British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own
E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (<=N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:
10
6 7 6 9 3 10 8 2 7 8

Sample Output:
6


题目大意:给出n天的骑车距离,求出爱丁顿数,其实就是求出E,这个E表示E天的骑行距离超过E英里。

这里需要理解的超过是大于还是大于等于,题目中说you are supposed to find the corresponding E (<=N).  说明超过的意思是大于。

思路:对给出的骑行距离排序后,从大到小扫描一遍就是答案。

证明:骑行距离从大到小排列后,假如第三天的距离小于3,再次进行扫描的时候,第四天的距离比3还小,肯定不会大于4,第五天的数据更小,同理,之后的越来越小,因此2就是答案,这个2不会更大。

#include<cstdio>
#include<algorithm>
#define N 100001
using namespace std;
int j,n,ans,a
;
int main(){
scanf("%d",&n);
//数据输入
for(int i=0 ;i<n ;i++) scanf("%d",&a[i]);

sort(a,a+n);
//数据处理
for(j=n-1,ans=1 ;j>=0 ;j--,ans++){
if(a[j]<=ans)break;
}
//因为当判断到<=才退出循环,因此答案是前一天
printf("%d\n",ans-1);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: