您的位置:首页 > 其它

POJ1789--Truck History(最小生成树)

2017-07-29 09:54 267 查看
Do more with less

Discussion

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company’s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan – i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text “The highest possible quality is 1/Q.”, where 1/Q is the quality of the best derivation plan.

Sample Input

4

aaaaaaa

baaaaaa

abaaaaa

aabaaaa

0

Sample Output

The highest possible quality is 1/3.

题意

每一行字符串代表一种车的编号,两个字符串之间不同字符的数量代表两种车之间的差距,新车又旧车衍生出来,代价是两种车之间的差距,一开始只有一种车,求所有车都衍生出来共需要的最小代价。

思路

最小生成树。

代码

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

struct node{
int s;
int e;
int v;

}stu[4000005];
char a[2002][7];
int p[2002];
int dis(int x,int y)
{
int ans = 0;
for(int i = 0; i < 7; i ++)
if(a[x][i] != a[y][i])
ans ++;
return ans;
}
int find(int x)
{
if(p[x] != x)
p[x] = find(p[x]);
return p[x];
}
bool cmp(node x, node y)
{
return x.v < y.v;
}
int main()
{
int n;
while(cin>>n && n)
{
for(int i = 0; i < n; i ++)
{
cin>>a[i];
p[i] = i;
}
int k = 1;
for(int i = 0; i < n-1; i ++)
{
for(int j = i+1; j < n; j ++)
{
stu[k].s = i;
stu[k].e = j;
stu[k++].v = dis(i,j);
}
}
sort(stu+1,stu+k+1,cmp);
int num = 0;
for(int i = 1; i <= k; i ++)
{
int x = find(stu[i].s);
int y = find(stu[i].e);
if(x != y)
{
num += stu[i].v;
p[x] = y;
}
}
cout<<"The highest possible quality is 1/"<<num<<"."<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: